Jump to content

   View New Content Mark all as read |  


3 day old Barnett Predator Problems


  • Please log in to reply
 

#1 westpadeadeye

westpadeadeye

    Member

  • Members
  • 44 posts

Posted 18 October 2010 - 08:21 PM

I bought a predator avi. After about 20 shots i noticed the cable looked like a chunch was taken out of it. Im really disappointed. Before that i could get the mounting rail to stay tight to sight it in.

Please help...I send Barnett a email but no response.. Ive read that the cable issue is common problem..Sounds like a serious problem to me. Ive had this thing for 3 days and im already out of commision...Im afraid it will blow up with the frayed cable...

Can someone please help.

thanks
lkarry

#2 SPECIALIZED

SPECIALIZED

    Super Moderator

  • Super Moderators
  • 5,533 posts

Posted 18 October 2010 - 08:31 PM

Sometimes the e-mail is really slow to respond ,give them a call/
Call Us
Phone: 1-727-234-4962
Fax: 1-727-942-6100

#3 vaguru

vaguru

    Senior Member

  • Members
  • 971 posts

Posted 18 October 2010 - 08:48 PM

I bought a predator avi. After about 20 shots i noticed the cable looked like a chunch was taken out of it. Im really disappointed. Before that i could get the mounting rail to stay tight to sight it in.

Please help...I send Barnett a email but no response.. Ive read that the cable issue is common problem..Sounds like a serious problem to me. Ive had this thing for 3 days and im already out of commision...Im afraid it will blow up with the frayed cable...

Can someone please help.

thanks
lkarry



Send me a PM with your complete name, address and phone number. I'll see what I can do.

#4 westpadeadeye

westpadeadeye

    Member

  • Members
  • 44 posts

Posted 18 October 2010 - 09:18 PM

Send me a PM with your complete name, address and phone number. I'll see what I can do.



message sent in pm..
'
thanks
again

#5 vaguru

vaguru

    Senior Member

  • Members
  • 971 posts

Posted 18 October 2010 - 09:43 PM

Pm replied

#6 westpadeadeye

westpadeadeye

    Member

  • Members
  • 44 posts

Posted 20 October 2010 - 10:31 PM

solution has been found..

With the help of a very generous member ive gotten all the advice and hellp i could need..

I resolved the scope mount loosening with some threadlock...no biggie.

As far as the cables fraying i called barnett and they are shipping me out a new set. But i still wasnt satisfied. I just spent 600 bucks on a crossbow and shot it 25 times and im out of commision. I also will have to pay to get them put on crossbow. So i called back. I hate to complain but felt i was 100% in right to be upset. They then offered me free 5 bolts to offset cost of getting cables put on..All in all still kinda upset about it but i believe barnett did a good job trying to make it right. I think anyone who spends 600 dollars and has issues right out of the gate would be a little upset about it even though they tried to make it right...

#7 potshot

potshot

    Member

  • Members
  • 163 posts
  • LocationSan Antonio

Posted 20 October 2010 - 10:45 PM

I think you are right to be a little upset but they listened to your complaint and are trying to make it right. But why not an even half dozen instead of 5 arrows.

#8 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 20 October 2010 - 11:30 PM

its good to here you they took care of the problem.on the arrows they pack them in a 5 pk that the way they ship them

#9 dedend

dedend

    Member

  • Members
  • 9 posts

Posted 25 October 2010 - 01:43 PM

Call back Barnett and get a Cable slide that fits in the Cable groove it's free and you get many more shots out of your cables. Also I have found the Bow shops that assemble your bow and you buy it hanging up do not wax the cables at all at assembly. So you go home and think they assembled this to the owners manual but 9 times out of 10 they don't and I did not even get the box.

#10 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 26 October 2010 - 08:44 AM

i dont think the cable slide will work on this xbow ,only the wildcat and jackel that what i heard but i chould be wrong

#11 westpadeadeye

westpadeadeye

    Member

  • Members
  • 44 posts

Posted 26 October 2010 - 09:03 PM

i dont think the cable slide will work on this xbow ,only the wildcat and jackel that what i heard but i chould be wrong


\
does anyone know if the cable slide would work..i really hope it would...

#12 poindexter

poindexter

    Advanced Member

  • Members
  • 580 posts

Posted 26 October 2010 - 09:16 PM

Could someone explain what a rail slide is and will it work on the RC150? Poindexter

#13 poindexter

poindexter

    Advanced Member

  • Members
  • 580 posts

Posted 26 October 2010 - 09:17 PM

opps I can't read. what is a cable slide not rail slide..... Poindexter

#14 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 26 October 2010 - 10:44 PM

a cable slide goes on the cable under the rail so the cables dont touch and rub

#15 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 27 October 2010 - 06:33 AM

no the slide will not work on the rc 150 because on the cable angal

#16 See4miles

See4miles

    Advanced Member

  • Members
  • 772 posts
  • LocationSt. Helen, MI (Home of Heston)

Posted 27 October 2010 - 10:19 PM

Last one I seen used teflon tape where the cable contacted the riser.

#17 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 28 October 2010 - 08:09 AM

look on the cable slide topic that should answer your ?