Jump to content

   View New Content Mark all as read |  


Buck Commander... Blew up!!!


  • Please log in to reply
 

#1 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 28 November 2010 - 01:02 PM

Pretty Angry right now! I have owned a barnett buck commander crossbow for about a month and Ive shot this crossbow maybe 25 times max! Lubeing the string and rail like you are supposed to based on the instructions... After hunting this morning, put in one of the arrows with a field tip on it to unload it and the string blew up and arrow went flying. How do I go about getting this fixed under warranty and what about the limbs... Are they damaged from this??? I am at a loss of words!

#2 JWG

JWG

    Junior Member

  • Members
  • 403 posts
  • Locationwoodlawn il. jefferson cty.

Posted 28 November 2010 - 01:39 PM

get ahold of vaguru he can help you get fast service fro factory. or call the factory service department.i have a predator an have dryfired it several times breaking string an didn't seam to do any damage to string.if you don't have a bow press you will have to take to bow shop to get string an have cables checked.where you live i have extra string an cables an bow press i live in sothern ill'

#3 JWG

JWG

    Junior Member

  • Members
  • 403 posts
  • Locationwoodlawn il. jefferson cty.

Posted 28 November 2010 - 01:41 PM

ment to say didn't do any damage to limbs or cables when dryfired

#4 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 28 November 2010 - 01:58 PM

Im in GA. Thanks for the help. I still cant believe this happened after 25 shots. And lucky didnt get hurt from it! Is this what I should expect out of barnett?

#5 JWG

JWG

    Junior Member

  • Members
  • 403 posts
  • Locationwoodlawn il. jefferson cty.

Posted 28 November 2010 - 02:11 PM

don't get to discuraged.my predator blew up 4 or fifth time i shot it siteing it in.i had arrow in it but may have turned wrong with nock turned wrong it broke three strings an i sent it back.no more problems.i also have a DOA barnett .it has predator front with a quad 400 style stock and i have a quad AVI and an excal exocet. i like them all.at least with barnetts i don't get board,there fast and accurate an i have something to play with. good luck hope you get back hunting soon.

#6 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 28 November 2010 - 05:57 PM

Looking at the busted string.. It broke at the serving area where it attaches to the cams on both sides.

#7 Timberframe

Timberframe

    Member

  • Members
  • 118 posts

Posted 28 November 2010 - 09:21 PM

Pretty Angry right now! I have owned a barnett buck commander crossbow for about a month and Ive shot this crossbow maybe 25 times max! Lubeing the string and rail like you are supposed to based on the instructions... After hunting this morning, put in one of the arrows with a field tip on it to unload it and the string blew up and arrow went flying. How do I go about getting this fixed under warranty and what about the limbs... Are they damaged from this??? I am at a loss of words!

Damn Passinthru, You got my attention. I just purchased the buck commander. I havent even shot a arrow out of it yet. Hope my string does better than yours. Anyways I hope Barnett takes care of you. Good luck and keep us informed on your progress.

#8 vaguru

vaguru

    Senior Member

  • Members
  • 971 posts

Posted 29 November 2010 - 08:56 AM

Passin,

Replied to your PM. Call Barnett CS. Does sound like a nock alignment/broken nock issue as previously mentioned. At any rate, Barnett will get you back up.

timber,

I wouldn't worry too much, I have well over 500 shots on my BC without issue. Just check nock each time you shoot.

#9 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 29 November 2010 - 09:30 AM

Called customer service this morning and got an RA number. Its gonna be about a 2 week turnaround. Very helpful customer service. But I dont see how a nock issue would have caused the string to break at the spots it attatches to the cams on both sides. What I think it could be, like they suggested was some burrs durning the machining of the cams and slowly cut the string. Regardless, its gonna be fixed and hopefully does not happen again. Besides this I was very happy with the crossbow. Quiet, for a crossbow and super fast. I hope this was just a random occurance. But very happy with the customer service and will use my Mathews in the time being.

#10 tryinhardarcher

tryinhardarcher

    Member

  • Members
  • 455 posts
  • LocationVirginia

Posted 08 December 2010 - 11:44 AM

Called customer service this morning and got an RA number. Its gonna be about a 2 week turnaround. Very helpful customer service. But I dont see how a nock issue would have caused the string to break at the spots it attatches to the cams on both sides. What I think it could be, like they suggested was some burrs durning the machining of the cams and slowly cut the string. Regardless, its gonna be fixed and hopefully does not happen again. Besides this I was very happy with the crossbow. Quiet, for a crossbow and super fast. I hope this was just a random occurance. But very happy with the customer service and will use my Mathews in the time being.


What caused your string to break I dont know, but it happens. Not all the time, and not frequently but it does and on all makes and models of crossbows. The string on a crossbow sees extream amounts of shock and vibration, and some times they fail. It does sound like a possible nock alignment issue, and when that happens that the strings normally break on the ends exactly like you described.
Matt

#11 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 10 December 2010 - 02:12 PM

its just a bad string ,it happens

#12 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 12 December 2010 - 07:53 PM

Barnett has had it about 1.5 weeks now so hopefully I will find something out soon or get it back this week.

#13 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 13 December 2010 - 11:28 AM

call cs they should know when you should get it back

#14 poindexter

poindexter

    Advanced Member

  • Members
  • 568 posts

Posted 13 December 2010 - 10:51 PM

call cs they should know when you should get it back

Passinthru, sorry to hear of your trouble. I have a buck commander that I purchased before this hunting season, and I have taken three deer with it so far. I had and issue with the cocking device but barnett took care of that with no problem, also I had a problem with the original string, the server seperated where the cocking device hooks to it when cocking. Again Barnett took care of that issue and all is well. Don't despair, the BC is a great xbow and you will enjoy your hunts with it....Poindexter

#15 Moon

Moon

    Senior Member

  • Members
  • 4,301 posts

Posted 14 December 2010 - 10:05 PM

Moon nocks again, Vaguru?

#16 vaguru

vaguru

    Senior Member

  • Members
  • 971 posts

Posted 15 December 2010 - 11:26 AM

Moon,

Could have been a nock not aligned proprerly, or.....arrow not up against the srting. Could be the arrow retention spring was a tad too loose, don't think I'd blame the moon nock without personally seeing the bow.

I currently have just over 600 shots on my Buck Commander, without issue. BTW, I just reserved the center serving for the first time, 602 shots logged. Best serving life I ever had!

#17 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 15 December 2010 - 03:46 PM

I am probably going to call if I dont get it back by Friday but not in a huge hurry. I am going through some recovery of a ruptured achilles tendon, main reason I bought the crossbow instead of using my mathews switchback xt. Makes it easier to hunt without having to stand up in the stand putting pressure on my leg. But thanks for all the feedback.

#18 Passinthru

Passinthru

    Member

  • Members
  • 11 posts

Posted 16 December 2010 - 06:26 PM

Crossbow was delivered today. It really looks like they just sent me another one. I mean it had my quiver bracket on it and the rail for the scope looks like it could have come from mine but overall it looks like it was just swapped out for a new one. Didnt even have any residue where the lube was on the rail. Hopefully everything works out on this one.

#19 outrunner13

outrunner13

    Member

  • Members
  • 182 posts
  • Locationbrooksville fla

Posted 16 December 2010 - 07:29 PM

its good to hear that you got xbow back