Jump to content

   View New Content Mark all as read |  


Cable slide problem


  • Please log in to reply
 

#1 Buck Buster

Buck Buster

    Flying Dutchman

  • Members
  • 1,543 posts

Posted 15 January 2011 - 05:54 PM

Does anyone had any problems with the cable slide of the Buck Buster?

#2 crowhunter

crowhunter

    Member

  • Members
  • 43 posts

Posted 15 January 2011 - 09:41 PM

I had my Terminator lose a cable slide, Parker sent me a couple and it has not had another one come out ,give Parker a call they have been great about helping me out .Bud

#3 Sean

Sean

    Member

  • Members
  • 144 posts

Posted 15 January 2011 - 09:52 PM

Does anyone had any problems with the cable slide of the Buck Buster?



what problem exactly?

#4 Cossack

Cossack

    Incurable Tinkerer

  • Members
  • 3,547 posts
  • LocationNo MN

Posted 17 January 2011 - 12:34 PM

what problem exactly?



If by problem you mean the slide backing out, not uncommon. Fist make sure the slide is in installed correctly, grooves should match the angle of the cables, etc.. Next, wax the cables to reduce friction. If all else fails, change the cables side to side. Don't know why it works but that did the trick on my Terminator.

#5 Sean

Sean

    Member

  • Members
  • 144 posts

Posted 17 January 2011 - 03:02 PM

I know there was some cable slides that went out that where a little thicker than normal and may bind a bit when cocking.

#6 Buck Buster

Buck Buster

    Flying Dutchman

  • Members
  • 1,543 posts

Posted 17 January 2011 - 04:37 PM

Hello guys thanks for info. I was shooting the bow, and suddenly wierd shot. I found out that cable slide sprung out. I called Parker and they send me a new one. If install this new, should the problem be over? How do you instal the new one? i never had this problem before.

#7 Cossack

Cossack

    Incurable Tinkerer

  • Members
  • 3,547 posts
  • LocationNo MN

Posted 18 January 2011 - 08:44 AM

Hello guys thanks for info. I was shooting the bow, and suddenly wierd shot. I found out that cable slide sprung out. I called Parker and they send me a new one. If install this new, should the problem be over? How do you instal the new one? i never had this problem before.


The slide has grooves that match the angle of the cables, into which the cables fit. Slide it in, Try to get some wax, or teflon or silicone spray, on the forearm groove where the slide fits to lube it''s passage.

#8 Buck Buster

Buck Buster

    Flying Dutchman

  • Members
  • 1,543 posts

Posted 18 January 2011 - 04:07 PM

Thanks, i will try this.