Jump to content

   View New Content Mark all as read |  


predator problems


  • Please log in to reply
 

#1 little mike

little mike

    Newbie

  • Members
  • 2 posts
  • Locationnc mountains

Posted 16 August 2012 - 10:15 AM

had a sring break on my barnett predator and it bent both cams has anyone else had this problem and is ther anything i can do to prevent this from happing again

#2 Cossack

Cossack

    Incurable Tinkerer

  • Members
  • 3,633 posts
  • LocationNo MN

Posted 16 August 2012 - 12:28 PM

had a sring break on my barnett predator and it bent both cams has anyone else had this problem and is ther anything i can do to prevent this from happing again


1> Buy quality strings, I had a factory string break also, now make my own
2> Change string when serving is worn-before latches start wearing string itself.
3>Check you nocks for sharp/rough edges, smooth if necessary
4> Change your string out once a yr if you shoot a lot, biannually if not much.

#3 little mike

little mike

    Newbie

  • Members
  • 2 posts
  • Locationnc mountains

Posted 16 August 2012 - 01:01 PM

thanks for the info the srting that broke was a factory barnett and only had 15-20 shots and the strange thing is it broke on both sides wher it is attaches to the cams so i thought ( and i could be wrong) that the nock could not have been the problem. what concerns me more is how sever it bent both cams. this is my first crossbow so i am pretty green and trying to learn

#4 Rio

Rio

    Member

  • Members
  • 151 posts

Posted 16 August 2012 - 01:02 PM

Cousin had his break first shot. It is at Barnett awaiting repair/replacement

#5 swampy

swampy

    Advanced Member

  • Members
  • 657 posts
  • LocationSplendora,Tx

Posted 16 August 2012 - 07:30 PM

Guy's I bought some viper x strings and so for so good. It brought my bow speed up about ten feet fps more.

#6 dbllungem

dbllungem

    Member

  • Members
  • 139 posts
  • LocationMichigan

Posted 16 August 2012 - 08:37 PM

X2 on the viperX...

#7 barnettxbows400

barnettxbows400

    Barnett Representative

  • Members
  • 1,024 posts
  • LocationFlorida

Posted 17 August 2012 - 02:49 PM

Mike,

Please give our customer service department a call at 727-234-4999 and we would be glad to help you out, and figure out what happend. Look forward to hearing from you.

-Jesse

#8 gendoc

gendoc

    Member

  • Members
  • 494 posts
  • Locationlowest bama

Posted 17 August 2012 - 07:34 PM

main thing about these barnett guy's is... there always happy to assist you with problems and repairs !!!
its great to know that your in excellent hands.............. :yahoo:

#9 swampy

swampy

    Advanced Member

  • Members
  • 657 posts
  • LocationSplendora,Tx

Posted 17 August 2012 - 09:45 PM

Yep Gendoc they are good folks and will help you anyway they can.

#10 dmllr134

dmllr134

    Member

  • Members
  • 5 posts

Posted 27 August 2012 - 02:59 PM

Do not forget to Lube the Rail at least every 5 Shots..I use Rail Snot...I shoot a lot (Over 250 shots this year) and my factory serving looks great!

#11 awbarrier

awbarrier

    Newbie

  • Members
  • 2 posts

Posted 27 August 2012 - 11:11 PM

I had the same issue with my penetrator, less than a yr old and the string broke messing both cams up..
i called a factory customer service rep. The lady told me i dry fired the bow ! I have hunted for 30+ yrs
and i know i didnt. Our season opens in 2 weeks and had a hunt planned for the end of sept. in Ohio.
I bought the Xbow from Barrnette (Bass pro) for their reputation and paid $600.00 for a Quality product
and service.. This is upsetting especially with season opening in a little less than two weeks and if i send
it back God only knows when i will get to hunt?

Edited by awbarrier, 27 August 2012 - 11:17 PM.


#12 Thunderbolt

Thunderbolt

    Member

  • Members
  • 1,092 posts
  • LocationMontgromery county,Pa

Posted 28 August 2012 - 05:20 PM

When its time...I'm also going to viper Strings myself...

#13 Thunderbolt

Thunderbolt

    Member

  • Members
  • 1,092 posts
  • LocationMontgromery county,Pa

Posted 28 August 2012 - 05:21 PM

I had the same issue with my penetrator, less than a yr old and the string broke messing both cams up..
i called a factory customer service rep. The lady told me i dry fired the bow ! I have hunted for 30+ yrs
and i know i didnt. Our season opens in 2 weeks and had a hunt planned for the end of sept. in Ohio.
I bought the Xbow from Barrnette (Bass pro) for their reputation and paid $600.00 for a Quality product
and service.. This is upsetting especially with season opening in a little less than two weeks and if i send
it back God only knows when i will get to hunt?

aw their turn over is pretty fast....and their CS is awsome....I'd go for it...who knows...Thunderbolt

#14 ScottyD

ScottyD

    Newbie

  • Members
  • 1 posts

Posted 01 October 2012 - 05:16 PM

Shot my new predator Sundsy for the first time. First shot was low at 20 yds. I adjusted the scope and fired the second shot, and to my surprise, the string broke on both ends, and the arrow flew back and whacked me in the forehead. Not sure what happened, but it sure took me by surprise. I have left messages with customer service, but have yet heard from them. Has anyone else had a problem like this ?

#15 barnettxbows400

barnettxbows400

    Barnett Representative

  • Members
  • 1,024 posts
  • LocationFlorida

Posted 03 October 2012 - 01:27 PM

Scott,

Has anyone given you a call back? If not Pm me your phone number and i will be happy to adress the issue.

-Jesse