Jump to content

   View New Content Mark all as read |  


Primos Blackout Truthcam review


  • Please log in to reply
 

#1 Jack Pine

Jack Pine

    Crossbow Nut

  • Members
  • 1,274 posts
  • LocationNorthern MI

Posted 31 August 2012 - 11:49 AM

Recently purchased a new Primos Truth Cam Blackout CR [close range], model 63037. The reason I chose this particular camera was because I didn't want to see any more deer spooked by the red glow of the emitters on my old [WGI] cam, or get pix of deer staring into it.
Some of the other reasons were, it is easy to program [slide switches], and stamps the moon phase, temperature date and time on the image. It also has a hole going through it so that you can secure it with a cable lock. It seemed very well thought out.
After using it for a week, it began to record video that it could not or would not play. After that, it would record what I could best describe as "false" or "phantom" files that wouldn't open or play, then It began to refuse to even recognize that it had an SD card in it, and consequently refused to record anything at all. Nothing at all wrong with the SD card; works fine in other devices and applications.
I took it back to Wal-Mart where I bought it, and to their credit, they exchanged it for another. This morning I checked it to find that it had 32 30-second video clips recorded, so I pulled the SD card and came home to watch. Fully 1/3 of the videos would not open or play.
Now, I know that anyone could possibly let a defective unit slip through, but after having 2, I can see a pattern forming. We all worry about our game cams getting stolen, but after having 2 of these, I'm convinced that most thieves will bring them back to you out of sheer frustration!
So here I am 30 days til season opener, running out of scouting time. It looks to me that the best option is to see if Wal-Mart will take this one back also so I can get another cam of another make before season. If Wal-Mart won't take it back [I wouldn't blame them, they didn't make the thing], then I will try to pursue a remedy through Primos; not likely I'll have this done by opener though.
Bottom line is this: If you value the time it takes to scout; time it takes to set out and monitor your cams; If you value your money [this cost $129], I would suggest you consider some other make of camera. It may well be that Primos made good cams in the past, and may again someday,and no doubt they would somehow make this right, but I'm done with Primos until I see a LOT of positive reviews by owners who have used them a while before I will buy another Primos product. Including some screen snips of what you can expect to see with a Primos Truth Cam Blackout CR. One of the snips shows a musical note instead of a video clip, apparently the thing thought it was playing an MP3! Don't waste your money.

Jack ><>

Attached Images

  • Primos1.PNG
  • Primos2.PNG
  • Primos3.PNG
  • Primos4.PNG


#2 xbsam

xbsam

    Member

  • Members
  • 330 posts
  • LocationLoganville, Georgia

Posted 31 August 2012 - 03:47 PM

Sorry to hear that. Best non-bias game camera review website that I know of is chasingame.com.

#3 CHUCHIP

CHUCHIP

    Advanced Member

  • Banned
  • 574 posts

Posted 31 August 2012 - 07:03 PM

Stay away from Primos trailcams folks! Bad experiences accross the board with these people!!! :angry:

#4 Jackal12

Jackal12

    Advanced Member

  • Members
  • 820 posts
  • LocationMissouri

Posted 27 November 2012 - 10:30 AM

As an owner of four of these cameras who has also had these issues, and resolved them, I can guarantee the problem is in fact the SD Card. As a computer guy these issues stood out to me much like the issues you have when using an SD card across multiple systems, for example Windows and Linux. Basically it is data corruption because the trail camera and your computer are not sharing the files properly.

The fix is to take the card (in some rare cases you may need a new one) and use a program like Partition Magic. What you want to do is delete the entire partition table. Then create a new partition in the FAT32 format, and choose the option to use all available space. Then format this new partition, making sure to use FAT32 again if you are prompted.

Now put it in the camera, trigger it a few times, then power the camera OFF and remove the card. Leaving the camera on can cause issues also, and that is not unique to this model or brand or even trail cameras that can be any device. Put the card in the computer and I bet it works. Leave all of the files in tact (make notes if you need, but don't erase them but once a month or so) and safely remove it from the computer.

Viola.

Also that last picture indicates issues with your computer and that file format, not the file or camera itself.

#5 maxtor

maxtor

    Member

  • Members
  • 87 posts

Posted 27 November 2012 - 03:45 PM

Partition the sd card in fat32? My trail cam says to format the sd card in FAT ONLY ??

#6 Jackal12

Jackal12

    Advanced Member

  • Members
  • 820 posts
  • LocationMissouri

Posted 27 November 2012 - 04:16 PM

Mine are all using FAT32. I have never opened a user manual for a trail camera so no idea what it says. Most likely they mean FAT as in 16 or 32, and not other formats such as NTFS, EXT, etc

Edited by Jackal12, 27 November 2012 - 04:17 PM.


#7 xbsam

xbsam

    Member

  • Members
  • 330 posts
  • LocationLoganville, Georgia

Posted 27 November 2012 - 04:32 PM

Most likely they mean FAT as in 16 or 32, and not other formats such as NTFS, EXT, etc


You are correct.

#8 Jackal12

Jackal12

    Advanced Member

  • Members
  • 820 posts
  • LocationMissouri

Posted 27 November 2012 - 04:50 PM

Figured I was :)

#9 GQ-

GQ-

    Senior Member

  • Members
  • 2,563 posts
  • LocationCanada

Posted 22 December 2012 - 11:47 AM

Just use another video player on your computer or download a codec.
Real Player or Quick Time.

#10 Jackal12

Jackal12

    Advanced Member

  • Members
  • 820 posts
  • LocationMissouri

Posted 22 December 2012 - 11:57 AM

Just use another video player on your computer or download a codec.
Real Player or Quick Time.


That isn't the issue, it was/is a data corruption issue. A codec or even another player such as VLC won't change anything with the issues described. It's easily fixed, see my post.