Crossbow Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Only been active watching on the site a few weeks and already asking questions. I broke out the led sled last evening to sight in my Sniper and when I cocked the Sniper I glanced down and noticed that my left Cam had a bit of lean to it (Ill use lean as the best word I can come with). The right side does not seem to have any. The string crosses on the right side. I tried the best I could to get clear level pictures. Is this normal? Manufacture issue maybe? My arrow weight with lighted nock 20200715_172218.jpg 20200715_172316.jpg and 100 grain field point is over 400 grains. That attached pictures are the left cam and the right cam with the bow cocked.
Thanks folks
JK
 

·
Premium Member
Joined
·
1,122 Posts
Does not look right to me.
I am a newbie, however.
Will check my CP 370 Specialist (same thing essentially) when I get home tonight.
 

·
Happy Member
Joined
·
5,471 Posts
You need to press that bow to realign the string on the cam before it comes completely off! Good luck!


Sent from my iPhone X using Tapatalk
 
  • Like
Reactions: dynamo61

·
Registered
Joined
·
5,376 Posts
Not uncommon on a bow that's been shot some and its pretty easily corrected. Take it to a shop that can press the Sniper and correct the left cam angle. A couple twists on the left side lower yoke cable and that will be fixed.
 
  • Like
Reactions: JOE PA and dynamo61

·
Registered
Joined
·
8 Posts
Discussion Starter #5
UPDATE: Spent $12 today on it. Took it to a fella here in town and he fixed it right up. He had me cock it and shoot it a few times to make sure it was all set. Thanks for the help. I had no idea. Cant wait to shoot it in a bit when it sun gets behind the trees
 
1 - 5 of 5 Posts
Top