Crossbow Nation banner

1 - 20 of 34 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Is anyone else having trouble with the camo coating peeling off the limbs on a TenPoint crossbow? Bought a new Vapor RS470 and peeling off after probably 50 shots or less. Also had an issue with the AccuSlide mechanism and had to have it replaced already.
I would expect better quality for the price of this now.
 

Attachments

·
Registered
Joined
·
2,554 Posts
Brother thats not camo coming off.....thats a limb splinter...or not

At any rate I would want it taken care of.....expensive bow or not !
 

·
Happy Member
Joined
·
5,437 Posts
I said the same thing on the other thread that he posted.


Sent from my iPhone X using Tapatalk
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Brother thats not camo coming off.....thats a limb splinter...or not

At any rate I would want it taken care of.....expensive bow or not !
Thanks, I have sent pictures to the store where I purchased it and will contact them again Friday. So far I am a little disappointed with this crossbow. First the AccuSlide issue now this and I haven’t even taken it to the field yet.
 

·
Registered
Joined
·
5,351 Posts
Thanks, I have sent pictures to the store where I purchased it and will contact them again Friday. So far I am a little disappointed with this crossbow. First the AccuSlide issue now this and I haven’t even taken it to the field yet.
I'd suggest going back to them and getting an exchange for a new Vapor. What was your issue with the ACUslide?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
I'd suggest going back to them and getting an exchange for a new Vapor. What was your issue with the ACUslide?
After about 12-15 shots the AccuSlide started making noises when you would be cocking they bow. I took it to the shop where I purchased it and they rebuilt the mechanism around three times, and they saw the same thing each time. Yesterday morning they put a completely new AccuSlide mechanism in and it worked fine. My son and I shot it around 10 after that and that is when we noticed the limb issue.
My first time with a crossbow and the experience isn’t what I expected so far.
 

·
Registered
Joined
·
5,351 Posts
After about 12-15 shots the AccuSlide started making noises when you would be cocking they bow. I took it to the shop where I purchased it and they rebuilt the mechanism around three times, and they saw the same thing each time. Yesterday morning they put a completely new AccuSlide mechanism in and it worked fine. My son and I shot it around 10 after that and that is when we noticed the limb issue.
My first time with a crossbow and the experience isn’t what I expected so far.
I'm curious about your issue Andy and for a couple reasons. I see and hear of folks having issues with the new system and wonder if it's a quality issue, design issue or user issue. Maybe it's a combination?

There are a small number of forum threads of accidental dry fires casing some stress on the trigger ADF, which in some cases causes problems with the trigger assembly working correctly. I've used a Vapor and Viper for a short time (2 weeks) and this was very early in the year and I didn't have any issue. I have a Vapor on order and naturally I want to be familiar with best practices for use and maintenance.

As for the shop you had service your bow. Did they say exactly what they did? I don't think any dealer has spare parts to "rebuild" anything? And why would they pull parts off a good new bow vs swapping out your problematic bow with a new one? More curiosity ;)

Thanks for sharing your info.!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #8
They told me that they pulled the assembly apart and saw that the disc inside had some glazing on them. They sanded the glazing off then reassemble the mechanism. It worked well for 12-15 shots then started making noise again.
They did not have another vapor in stock (other than the black model) so they pulled the entire AccuSlide mechanism out of another bow and put it in mine. It now works as it should, now the limb problem.
I think I will call them tomorrow and try to swap it out with the other one. Pennsylvania season opener is in three weeks.
I would have thought that all of this engineering was tested in great detail before they took it to market, but I do think there is a lot of stress in this bow that may be causing some issues.
 

·
Registered
Joined
·
2,745 Posts
It's not just Tenpoint though! It seems the quest for speed has taken a toll on quality.....Most all the narrow,fast bows are having some issues! Technology has surpassed the materials needed to handle the changes!
Strings,limbs,cranks,= Too much stress!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
Just talked to the shop where I purchased this bow, they stated Tenpoint would not replace it since it has already been registered and is now considered a used bow. They are ordering new limbs for it and will replace them when they come in. Not real happy at this point.....
 

·
Registered
Joined
·
5,351 Posts
Just talked to the shop where I purchased this bow, they stated Tenpoint would not replace it since it has already been registered and is now considered a used bow. They are ordering new limbs for it and will replace them when they come in. Not real happy at this point.....
IMO, that's a shop issue Andy, not yours but it's clear they don't want to take the responsibility. Out of box failures, registered or not shouldn't be an issue the customer has to deal with. If this was a customer damaged bow, that's a whole other discussion.

As for the limbs and technology used on your Vapor, TenPoint has tested it and used it continuously since 2017 so it's far from new. The Nitro X was the public introduction and the XRT followed and I've not seen or heard of many if any limb issues on the RDX bows. I've owned both of those bows and outside of string care and occasional cam angle adjustment, they have been awesome xbows.

I wish you luck with the repair on your bow!
 
  • Like
Reactions: dynamo61

·
Registered
Joined
·
377 Posts
I would NOT take ANY shops word on what they CLAIM the manufacturer told them about replacing your bow or anything else for that matter. Why did you not contact TenPoint directly with any of these issues? I strongly suggest you message Randy Wood. (10ptCrossbow) He is the TenPoint representative who frequents this forum. Aside from being the most knowledgeable 10Pt person here, he is also one hell of a nice guy and has been a HUGE help to many of us. If there is any help/remedy for your situation, he is the person that can provide it.
 

·
Premium Member
Joined
·
1,074 Posts
  • Like
Reactions: Tnmtns

·
Registered
Joined
·
2,745 Posts
Just talked to the shop where I purchased this bow, they stated Tenpoint would not replace it since it has already been registered and is now considered a used bow. They are ordering new limbs for it and will replace them when they come in. Not real happy at this point.....
If you bought that bow new from the dealer,it doesn't sound right that TenPoint would consider it a used bow! Of course it's USED now,but by the original owner..... You need to go over the dealers head on this one!
 

·
Registered
Joined
·
12 Posts
I had the camo come off the rail of my Turbo GT. After a couple hundred shots. I decided to to remove the remaining camo of the rail and to smooth it out. Thats a different story when hydro dip is coming off the limbs, could be limb splinter and I would definitely have it checked out.

Sent from my SM-G986U using Tapatalk
 

·
Registered
Joined
·
377 Posts
Andy...You had a post 4 days ago about your accuslide issues. One of the replies you got was from Randy, the TenPoint Rep. He asked you what shop your bow was at, and you replied "It's at Jim's Sports Center in Clearfield, PA". I am assuming Randy called them to find out what was going on with your bow and it's issues, and how they are handling it. Have you heard anything new or different since then?
 

·
Registered
Joined
·
8 Posts
Is anyone else having trouble with the camo coating peeling off the limbs on a TenPoint crossbow? Bought a new Vapor RS470 and peeling off after probably 50 shots or less. Also had an issue with the AccuSlide mechanism and had to have it replaced already.
I would expect better quality for the price of this now.
Yes it just started today less than 50 shots however they are sending limbs to local for me to have swapped out. My Vapor is 3 months old I just have to pay for service since I need this fixed ASAP. Hunting season just started yesterday. Sept 15th 2020. Let you know the outcome. How are you doing since it was fixed?
 
1 - 20 of 34 Posts
Top