Crossbow Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
205 Posts
Discussion Starter #1
Shot 15 arrows out of my Viper today. Shot awesome as usual only thing is I seem to noticed the acuslide is making a very faint whining noise as I’m getting close to full cock. The last three or so cranks before the trigger latch clicks in place. Anyone have any idea what this is about? Ohio season opens sept 26. Should I contact TP?

after shooting the viper I decided to shoot a few arrows out of my Vortec RDX. On the second cocking attempt my AcuSled broke! Luckily I had only drawn back a few inches when it broke so it didn’t damage the bow. I finished zeroing with the standard sled rope cocker. Not a good day for team USA and team Ohio.
 

·
Registered
Joined
·
205 Posts
Discussion Starter #2
Just went out and shot another 6 arrows through the viper and now I’m not hearing anything during the draw. Maybe I’m crazy. I’ve cocked and shot and cocked and decocked without any incident, Just seemed like the acuslide earlier had a slight audible noise at the end of the draw cycle.
 

·
Registered
Joined
·
377 Posts
Just went out and shot another 6 arrows through the viper and now I’m not hearing anything during the draw. Maybe I’m crazy. I’ve cocked and shot and cocked and decocked without any incident, Just seemed like the acuslide earlier had a slight audible noise at the end of the draw cycle.
Funny you mention this! I shot today and noticed the same thing! It was fine the first 15 or so shots, then it started to get quite stiff and started making a fair amount of noise the last few inches of cocking. I could noticeably feel it get harder to crank and felt the stress on the crank handle. My noise was more a squeal or squeak than a whining noise. Really did not feel right as compared to the earlier shots.
 

·
Registered
Joined
·
205 Posts
Discussion Starter #4
This is exactly what I had for 6 or so shots. Just as you describe
 
1 - 4 of 4 Posts
Top